Back to overview
Maintenance
server maintenence
Apr 30, 2026 at 2:20am UTC
–
Apr 30, 2026 at 3:20am UTC
Affected services
wisp.place
sites.wisp.place
Resolved
Apr 30, 2026 at 3:20am UTC
Maintenance ended
Affected services
Created
Apr 30, 2026 at 2:20am UTC
wisp will be gone for up to 20 minutes to perform server maintainence
Affected services